Skip to main content.

Updates for ELDK:

Patchset 389:

Fixes:
memory leak in appWeb web server
Changes:
Target RPMs for appWeb:

Old Package New Package
appWeb-ppc_*-1.2.2-1_5 appWeb-ppc_*-1.2.2-1_6
CVS Tags:
ELDK-3.0 LABEL_2004_12_25_2045

Patchset 390:

Fixes:
problems with native GCC on 6xx systems (symptoms: lmbench does not work correctly on MPC5200 etc.)
Changes:
Target RPMs for GCC/G++:

Old Package New Package
gcc-c++-ppc_*-3.3.3-10 gcc-c++-ppc_*-3.3.3-11
gcc-ppc_*-3.3.3-10 gcc-ppc_*-3.3.3-11
CVS Tags:
ELDK-3.0 LABEL_2004_12_25_2045

Patchset 391:

Fixes:
Improved the build script so that multiple ELDK builds can be run on the same host in parallel, and that all files are cleaned up upon interruption by Ctrl-C
Changes:
build.sh shell script; no changes visible to end users

Old Package New Package down
build.sh:1.29 build.sh:1.30
CVS Tags:
ELDK-3.0 none

Patchset 392:

Fixes:
binutils (gas) problem: the native assembler did not understand the "mftb" mnemonic
Changes:
Target RPMs for binutils:

Old Package New Package
binutils-ppc_*-2.14-7 binutils-ppc_*-2.14-8
CVS Tags:
ELDK-3.0 LABEL_2004_12_27_2315

Patchset 393:

Fixes:
Change ELDK version string to prepare for release of ELDK 3.1.1 (Bug Fix Release)
Changes:
Build Script and README files

Patchset 394:

Fixes:
ELDK_FIXOWNER does not work on FreeBSD where UID/GID "root" don't exist; ELDK_MAKEDEV did not create entries for /dev/hdb*
Changes:
ELDK_FIXOWNER and ELDK_MAKEDEV scripts:

Old Version New Version
ELDK_FIXOWNER 1.3 1.4
ELDK_MAKEDEV 1.4 1.5

Patchset 395:

Fixes:
makes install tool runnable under FreeBSD
Changes:
add FreeBSD's "brandelf" tool (plus needed header file) and "brand" the install program as Linux binary which is required for execution under FreeBSD:

No changes visible to user.

Patchset 400:

Fixes:
Update to PCMCIA Card Services to version 3.2.8
Changes:
new PCMCIA Card Services packages

Old Version New Version
pcmcia-cs 3.2.1-3 3.2.8-1

Patchset 401:

Fixes:
"passwd -d name" resulted in a segmentation fault.
Changes:
fixed configuration for libuser:

Old Version New Version
libuser-devel-ppc_*-0.51.7-1_2.ppc.rpm libuser-devel-ppc_*-0.51.7-1_3.ppc.rpm
libuser-ppc_*-0.51.7-1_2.ppc.rpm libuser-ppc_*-0.51.7-1_2.ppc.rpm

No Patchset:

Fixes:
setlocale() does not work; locale definitions are missing
Changes:
Update /usr/bin/localedef binary on the build host. The host system's localedef is invoked as part of the target glibc build process to generate the locale files. After the upgrade of the ELDK code base, the new glibc Makefile now invokes localedef with command line arguments that are not supported by the old version of localedef installed on the build host. This results in the fact that no locale files are generated.

No changes visible to end users.

Patchset 402:

Fixes:
Improved Support for PowerQUICC-III (MPC85xx) family. Preliminary version in the context of the current GCC/binutils using soft-float.
Changes:
Creates new ppc_85xx target packages

Old Version New Version
glibc-common 2.3.1-51a_7 2.3.1-51a_8
glibc 2.3.1-51a_7 2.3.1-51a_8
glibc-devel 2.3.1-51a_7 2.3.1-51a_8
glibc-utils 2.3.1-51a_7 2.3.1-51a_8
glibc-profile 2.3.1-51a_7 2.3.1-51a_8
libstdc++ 3.3.3-11 3.3.3-12
libstdc++-devel 3.3.3-11 3.3.3-12
cpp 3.3.3-11 3.3.3-12
gcc 3.3.3-11 3.3.3-12
gcc-c++ 3.3.3-11 3.3.3-12
binutils 2.14-8 2.14-9

-- WolfgangDenk - 15 Feb 2005