Skip to main content.

3.11. Notes for Solaris 2.x Host Environment

If you use a Solaris 2.x host environment, you need additional freeware packages (mostly GNU tools) to install and especially to build the ELDK packages. The following table lists all required packages that must be installed on the Solaris host system before attempting to build and/or install the ELDK. All these files except those marked with (**) (and the RPM and zlib-1.1.2 packages, which are available at ftp://rpmfind.net/linux/solaris are available for free download at ftp://ftp.sunfreeware.com/pub/freeware/sparc/2.6/

Necessary Freeware Packages:

Package Version down Instance File Name
gettext 0.10.37 SMCgtext gettext-0.10.37-sol26-sparc-local.gz
bzip2 1.0.1 SMCbzip2 bzip2-1.0.1-sol26-sparc-local.gz
zlib(**) 1.0.4 SMCzlib zlib-1.0.4-sol26-sparc-local.gz
zlib 1.1.2 - zlib-1.1.2.tar.gz
tar 1.13.19 SMCtar tar-1.13.19-sol26-sparc-local.gz
bison 1.28 SMCbison bison-1.28-sol26-sparc-local.gz
gzip 1.3 SMCgzip gzip-1.3-sol26-sparc-local
automake(**) 1.4 SMCautom automake-1.4-sol26-sparc-local.gz
libtool 1.4 SMClibt libtool-1.4-sol26-sparc-local.gz
m4 1.4 SMCm4 m4-1.4-sol26-sparc-local.gz
python 1.5.2 SMCpython python-1.5.2-sol26-sparc-local.gz
libiconv 1.6.1 SMClibi libiconv-1.6.1-sol26-sparc-local.gz
wget 1.7 SMCwget wget-1.7-sol26-sparc-local.gz
textutils 2.0 SMCtextu textutils-2.0-sol26-sparc-local.gz
bash 2.05 SMCbash bash-2.05-sol26-sparc-local.gz
binutils 2.11.2 SMCbinut binutils-2.11.2-sol26-sparc-local.gz
autoconf(**) 2.13 SMCautoc autoconf-2.13-sol26-sparc-local.gz
patch 2.5 FSFpatch patch-2.5-sol26-sparc-local.gz
rpm 2.5.2 RPM rpm-2.5.2.pkg
flex 2.5.4a FSFflex flex-2.5.4a-sol26-sparc-local.gz
diffutils 2.7 GNUdiffut diffutils-2.7-sol26-sparc-local.gz
gcc 2.95.3 SMCgcc gcc-2.95.3-sol26-sparc-local.gz
ddd(*) 3.0 TUBddd ddd-3.0-sol26-sparc-local.gz
sed 3.02 SMCsed sed-3.02-sol26-sparc-local.gz
gawk 3.1.0 SMCgawk gawk-3.1.0-sol26-sparc-local.gz
make(**) 3.79.1 SMCmake make-3.79.1-sol26-sparc-local.gz
fileutils 4.0 SMCfileu fileutils-4.0-sol26-sparc-local.gz
texinfo 4.0 SMCtexi texinfo-4.0-sol26-sparc-local.gz
perl(**) 5.005_03 SMCperl perl-5.005_03-sol26-sparc-local.gz
ncurses 5.2 SMCncurs ncurses-5.2-sol26-sparc-local.gz
expect(*) 5.25 NTexpect expect-5.25-sol26-sparc-local.gz
unzip 5.32 IZunzip unzip-5.32-sol26-sparc-local.gz
tcl(*) 8.3.3 SMCtcl tcl-8.3.3-sol26-sparc-local.gz

The packages marked "(*)" are not absolutely required, but sooner or later you will need them anyway so we recommend to install them.

The packages marked "(**)" are older versions of the ones currently available at ftp://ftp.sunfreeware.com/pub/freeware/sparc/2.6/. You can obtain them from the DENX public FTP server.

The following symbolic links must be created in order to be able to build the ELDK on a Solaris machine:

/usr/local/bin/cc  --> /usr/local/bin/gcc
/usr/lib/libiconv.so.2 --> /usr/local/lib/libiconv.so.2
/usr/lib/libncurses.so.5 --> /usr/local/lib/libncurses.so.5

Additionally, to be able to build the ELDK on Solaris, you must place newer GNU gettext macros to the /usr/local/share/aclocal directory. This can be accomplished as follows:

3.10. Rebuilding the ELDK from Scratch 1. Abstract 4. System Setup
Prev Home Next